Just Labradors banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi,

My 6 month old Lab has been having problems with UTI's since we brought her home at 3 months old. She had a raging(realllly bad) UTI with the puss count up really high, my vet put her on a antibiotic for 14 days. We tested her urine, puss count was still high, so we put her on another dose of antibiotics. The infection seemed to be getting alittle better then it started to get worse. My vet did a test to see what antibiotic would kill the infection and put her on Clavamox.
We started noticing that after she pees she had white puss(we thought it was a discharge, but vet said it was puss). Now she gets a yellow discharge/puss thats kinda stringy.

She just turned 6 months old on Oct. 24 and we're looking to have her spayed. She was scheduled to have surgery today, but we canclled it because we don't know if the UTI's gone and didn't want to take any chances. We talked to our vet today and are doing a test to see if the infections gone(the results will be in tomorrow). Our vets wondering if there's something else going on besides a UTI. She said that its possible that she might have something wrong with her bladder or maybe a inverted vulva. She wasn't happy that she has a yellow discharge/puss and seemed concerned.

I know that alot of you have been through similiar situations with your labs and might have some insights as to what may be going on. Its getting frustrating not knowing whats wrong and what we're going to have to do to get her better(IE: surgery, let her go through a heat cycle, etc). ???


Thanks in advance!
 

·
Registered
Joined
·
539 Posts
Sounds like it could be vaginitis..Kallie has had it since she was a pup...she has a greenish discharge and has and inverted vulva...the only regret that I have is not waiting to have her spayed...we didn't know that the first heat usually fixes the vaginitis..now she is dealing with a nasty staph infection that I believe is due to her vaginitis and her constant licking...Hope she feels better soon..
 

·
Registered
Joined
·
358 Posts
Hi Equine Love! 

My 7 m/o lab Kaycie has had this since she was about 14 weeks old.  She has an inverted vulva that looks EXACTLY like this .....well that's because it's a picture of her.

We just finished our 3rd round of meds.  We first were put on Clavamox for 14 days, it worked ok.  About 3 weeks later....here we go again.  So then we're put on SMZ-TMP (a.k.a. Bactrim for the cystitis) twice a day for 10 days.  Well about a month after that, another infection.  We've just finished the medicine for that one.  We were put on Bactrim again, along w/ a urine acidifier, I wasn't sure of the name but it stinks to high heavens...and on the Vet Bill it says Methio-form.  It's kind of the same thing they give horses when they get leg wounds or scrapes, just in a pill form.

It's really an on going thing.  We're really REALLY going to do everything we can to hold off until after her first heat.  From the beginning Foster, the Vet, has recommended that we wait at least until a year because of the rate of it fixing itself.   Our vet, whom i'm totally devoted to, and wont have any other is a 3 hour drive sends us our medicine.  We drive back home to my Parents when we have doctors appointments, and have a local vet for emergencies. 

I'd just like for you to know that if you need anyone to talk to, I'd love to be your "shoulder to lean on".  It's hard to find people that are dealing with these sorts of things  so, please, If you have time ever, i'd love to keep in touch and maybe compare stories since we're kinda dealing with something similar.  My name's Amber.  and my pup's Kaycie.....HOPE these pictures dont freak you out.  But it might give you some "live" version of what an Inverted Vulva looks like.  This was Pre- medication the second infection, and it's pretty dark from her licking it so much


 
1 - 4 of 4 Posts
Top