Just Labradors banner

1 - 9 of 9 Posts

·
Registered
Joined
·
28,830 Posts
Discussion Starter #1
Well, it's a Panasonic, but anyway.

Remember on Saturday I got a replacement belt for my vac? And put it on all by myself? But I couldn't get the brush roller to... roll?

I did it! I had it looped over the wrong shaft in the back. There are two... one is stationary and one turns. I had it looped over the stationary one. The turning shaft is pretty well hidden, but I sought it out like a cat after a mouse.

My carpets are clean again!

Now, about my large window unit air conditioner... it's next.

:)
 

·
Registered
Joined
·
601 Posts
Congrats!! Why do appliances have to be stubborn at times?
 

·
Registered
Joined
·
28,830 Posts
Discussion Starter #4
Awesome...I did the same thing once, had it on wrong :)

what are you doing with the window unit?
The red light indicating "clean the filter" is on. But I've cleaned it and brushed out the grill that covers the coils. It's blowing cold air but that light is still on. I hate little niggles like that. I'm sure the A/C is working too hard trying to blow cold air into the house but I'm not sure what to do now.

I know there is a special A/C cleaning acid you can use (Tudor did that last year) but I am loathe to use it with the dogs and kitty around. Besides... I'd have to remove the unit from the window and that will be impossible for me to do.

Ideas? Anyone?
 

·
Registered
Joined
·
28,830 Posts
Discussion Starter #7

·
Registered
Joined
·
28,830 Posts
Discussion Starter #8
MWG! I think you're right! I just turned the power off to remove the filter again. The red light (filter light) stayed on. HUH? Light on with power off?

Sensor? Anyone else vote for sensor? I do. :)
 
1 - 9 of 9 Posts
Top